CCNP TSHOOT 642-832 config demo コンフィグデモ 試験対策

  • このエントリーをはてなブックマークに追加

TSHOOTについて
https://learningnetwork.cisco.com/docs/DOC-6577

実際の試験のトポロジー
https://learningnetwork.cisco.com/docs/DOC-6738

デモページ
http://www.cisco.com/web/learning/le3/le2/le37/le10/tshoot_demo.html

BOSONのデモ動画

黒本とPint-tのプレミアムコンテンツ1ヶ月2400円で試験対策十分って言われてるけど、受験料1回2万円で落ちるとだいぶショックだから安全策・保険をかける意味でクラムメディア8000円もやっといたほうが吉と思われ。
http://ping-t.com/
http://www.crammedia.com/

過去にクラムメディアやらないで黒本とPing-tでほぼ全問題回答できる状態で受けて、合格点に1点足りないとかふざけた点数で落ちたことあるからそれ以降クラムメディアはひととおり対策やった後の試験直前にやることにしてる。
1点足りなくて不合格とか・・・もうね完全にやる気なくすよ。

試験結果:
チケット問題(トラブルシュート)は100%正答で900点台後半で合格。合格点は790点。
試験のバグ2箇所はping-tの感想で言われている通りでた。
試験受けるまではciscoがわざとバグっぽいけど実は正しいっていうのをやってるんだと思ってたけど、やっぱりバグだと思う。
TSHOOTはどんな問題になっても、なにこれ?ってパニくらずに落ち着いて端から端まで間違え探しのように慎重に調べていくことが最重要なのかなと。

RouterとSwitch試験後に受ければよゆーらしいけど、受験後にしばらく経過してるとまぁ忘れてるよね。
復習用にBSCIとBCMSN時代の試験対策の中古本は安くておすすめ。これら数百円でTSHOOTの範囲の知識としてはほぼカバーできる。

ASW2のコンフィグ
hostname ASW2
interface FastEthernet1/0/1
description Link to FTP Server
spanning-tree portfast
switchport mode access
switchport access vlan 20
!
interface FastEthernet1/0/19
description Link to DSW2
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 24 mode on
!
interface FastEthernet1/0/20
description Link to DSW2
switchport trunk allowed vlan 20,200
switchport mode trunk
channel-group 24 mode on
!
interface FastEthernet1/0/21
description Link to DSW1
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 14 mode on
!
interface FastEthernet1/0/22
description Link to DSW1
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 14 mode on
!
interface Vlan200
ip address 192.168.1.132 255.255.255.224
!
ip default-gateway 192.168.1.130
!
end

FTP Server へのI/Fに
spanning-tree portfast を追加しました(必要ではありませんが)

————————————————————
ASW1のコンフィグ
hostname ASW1
!
interface Fa1/0/1
description Link to Client1
spanning-tree portfast
switchport mode access
switchport access vlan 10
switchport port-security
switchport port-security max-mac-count 1
switchport port-security violation shutdown
!
interface Fa1/0/2
description Link to Client2
spanning-tree portfast
switchport mode access
switchport access vlan 10
!
interface Fa1/0/19
description Trunk to DSW1
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
!
interface Fa1/0/20
description Trunk to DSW1
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
!
interface Fa1/0/21
description Trunk to DSW2
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
!
interface Fa1/0/22
description Trunk to DSW1
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
!
interface Vlan200
ip address 192.168.1.131 255.255.255.224
!
ip default-gateway 192.168.1.129
!
end

Client1へのI/Fにport-securityを設定しました
port-securityの構文はデバイスによって異なるみたいです

Client1へのI/Fに
spanning-tree portfastを追加

————————————————————
DSW2のコンフィグ
hostname DSW2
!
ipv6 unicast-routing
!
ip routing
!
interface Loopback2
no ip address
ipv6 address FEC0::22:2/122
ipv6 rip RIP_ZONE enable
!
interface Fa1/0/14
description Link to R4
no switchport
ip address 10.1.4.10 255.255.255.252
!!
interface Fa1/0/19
description Trunk to ASW2
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,200
channel-group 24 mode on
!
interface Fa1/0/20
description Trunk to ASW2
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,200
channel-group 24 mode on
!
interface Fa1/0/21
description Trunk to ASW1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,200
channel-group 23 mode on
!
interface Fa1/0/22
description Trunk to ASW1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,200
channel-group 23 mode on
!
interface port-channel 12
no switchport
ip address 10.2.4.14 255.255.255.252
ipv6 address 2026::3:2/122
ipv6 rip RIP_ZONE enable
!
interface Fa1/0/23
description Link to DSW1
no switchport
no ip address
channe-group 12 on
!
interface Fa1/0/24
description Link to DSW1
no switchport
no ip address
channe-group 12 on
!
interface Vlan10
ip address 10.2.1.2 255.255.255.0
!
interface Vlan20
ip address 10.2.2.1 255.255.255.0
!
interface Vlan200
ip address 192.168.1.130 255.255.255.224
!
standby 10 ip 10.2.1.254
standby 10 preempt
!
router eigrp 10
network 10.1.4.8 0.0.0.3
network 10.2.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 10.2.4.12 0.0.0.3
network 192.168.1.224 0.0.0.31
no auto-summary
!
ipv6 router rip RIP_ZONE
!
end

————————————————————
DSW1のコンフィグ
hostname DSW1
ipv6 unicast-routing
!
ip routing
!
interface Loopback1
no ip address
ipv6 address FEC0::11:1/122
ipv6 rip RIP_ZONE enable
!
interface Fa1/0/1
description Link to R4
no switchport
ip address 10.1.4.6 255.255.255.252
ipv6 address 2026::2:2/122
ipv6 rip RIP_ZONE enable
!
interface Fa1/0/19
description Trunk to ASW1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,200
channel-group 13 mode on
!
interface Fa1/0/20
description Trunk to ASW1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,200
channel-group 13 mode on
!
interface Fa1/0/21
description Trunk to ASW2
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,200
channel-group 14 mode on
!
interface Fa1/0/22
description Trunk to ASW2
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,200
channel-group 14 mode on
!
interface port-channel 12
no switchport
ip address 10.2.4.13 255.255.255.252
ipv6 address 2026::3:1/122
ipv6 rip RIP_ZONE enable
!
interface Fa1/0/23
description Link to DSW2
no switchport
no ip address
channe-group 12 on
!
interface Fa1/0/24
description Link to DSW2
no switchport
no ip address
channe-group 12 on
!
interface Vlan10
ip address 10.2.1.1 255.255.255.0
!
interface Vlan20
ip address 10.2.2.2 255.255.255.0
!
interface Vlan200
ip address 192.168.1.129 255.255.255.224
!
ip helper-address 10.1.4.5
!
standby 10 ip 10.2.1.254
standby 10 priority 150
standby 10 preempt
standby 10 track 10 decrement 60
!
track 1 ip route 10.2.4.13 255.255.255.252 metric threshold
threshold metric up 1 down 2
!
track 10 ip route 10.1.4.6 255.255.255.252 metric threshold
threshold metric up 63 down 64
!
router eigrp 10
variance 2
network 10.1.4.4 0.0.0.3
network 10.2.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 10.2.4.12 0.0.0.3
network 192.168.1.224 0.0.0.31
no auto-summary
!
ipv6 router rip RIP_ZONE
!
vlan access-map test1 10
match ip address 10
!
vlan filter test1 vlan-list 10
ip access-list standard 10
!
permit 10.2.0.0 0.0.255.255
!
end

EIGRP
RIPng
L2とL3のEtherChannel
VLAN
SVI
HSRP
ip helper-address

EtherChannel modeは、ON固定にしていますが
PAgP の modeミスが問題にされてしまうと、確認しきれないです。。。
L2のEtherChannelは、I/F設定に加えるだけなので、あまり意識しないですが
L3では論理I/Fを作るので、ややこしくなります。
(論理I/FにIPv6ルーテイングプロトコル設定する)

HSRPのstandbyは、trackを使っています
threshold metric up 63 down 64 の意味は良くわかりませんが、
I/F指定ではなく、IPアドレス指定にしています

spanning-tree mode pvst の設定が入るかなと思ったのですが
10と20がトランクされている所がないので、設定する意味が無いと思いました。
vlan200はネイティブなのでしょうか?
設定するなら
spanning-tree vlan 10 priority 4096
spanning-tree vlan 200 priority 0
とかでしょうか。

————————————————————
R4のコンフィグ
hostname R4
!
ip dhcp pool CLIENTS
network 10.2.1.0 255.255.255.0
default-router 10.2.1.254
!
ip dhcp excluded-address 10.2.1.1 10.2.1.2
ip dhcp excluded-address 10.2.1.254
!
!
ipv6 unicast-routing
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
ipv6 address FEC0::4:4/122
ipv6 ospf 6 area 34
!
interface Tunnel34
description Link to R3
no ip address
ipv6 address 2026::34:2/122
ipv6 ospf 6 area 34
tunnel source 10.1.1.10
tunnel destination 10.1.1.9
!
interface FastEthernet0/0
description Link to DSW1
ip address 10.1.4.5 255.255.255.252
ipv6 address 2026::2:1/122
ipv6 rip RIP_ZONE enable
!
interface FastEthernet0/1
description Link to DSW2
ip address 10.1.4.9 255.255.255.252
!
interface Serial1/3.34 point-to-point
description Link to R3
ip address 10.1.1.10 255.255.255.252
frame-relay interface-dlci 403
!
router eigrp 10
redistribute ospf 1 route-map OSPF>EIGRP
network 10.1.4.4 0.0.0.3
network 10.1.4.8 0.0.0.3
no auto-summary
!
router ospf 1
area 34 nssa
redistribute eigrp 10 metric 100 route-map EIGRP>OSPF subnets
network 4.4.4.4 0.0.0.0 area 34
network 10.1.1.8 0.0.0.3 area 34
!
ipv6 router ospf 6
redistribute rip RIP_ZONE !ここにも subnets いるのかな?
!
ipv6 router rip RIP_ZONE
redistribute ospf 6 metric 4
!
access-list 50 permit 10.1.1.0 0.0.0.255
access-list 50 permit 209.65.200.0 0.0.0.255
!
route-map OSPF>EIGRP permit 10
set metric 30000 1000 255 1 1500
match ip address 50
!
route-map EIGRP>OSPF deny 10
match ip address 50
!
route-map EIGRP>OSPF permit 20
!
end

R4は盛りだくさんです
DHCPサーバー
IPv6
Tunnel
OSPF
OSPFv3
EIGRP
RIPng
各再配送

dhcpサーバーの設定がよくわかりませんが、
show running-config の結果はこんな感じになるのでしょうか

IPv6の再配送がよくわからないです
というか、OSPFv3やRIPngがよくわかってない

再配送は
redistribute ? ? include-connected
というオプションを他所で見かけます。
connectedを指定しないと再配送しないのは、ISISと思うのです
なので、ここではconnected はつけていません

EIGRP>OSPF はルートマップにしなくてもいいですね。。。

OSPFv3のネクストホップはリンクローカルらしいのですが
ネクストホップというぐらいですから、loopbackじゃ駄目ですよね
追加でリンクローカルアドレスを設定する必要があるのでしょうか?
ipv6 address fe80::4 link-local
軽く調べてみた限り、設定はしないみたいですね
point-to-point ならば、グローバルでもいいらしいですが、
multipointではリンクローカルを設定しないと駄目みたいです。

————————————————————
R3のコンフィグ
hostname R3
ipv6 unicast-routing
!
interface Loopback3
ip address 3.3.3.3 255.255.255.255
ipv6 address FEC0::3:3/122
ipv6 ospf 6 area 0
!
interface Tunnel34
description Link to R4
no ip address
ipv6 address 2026::34:1/122
ipv6 ospf 6 area 34
tunnel source 10.1.1.9
tunnel destination 10.1.1.10
!
interface Serial0/0/0/0.23 point-to-point
description Link to R2
ip address 10.1.1.6 255.255.255.252
ipv6 address 2026::1:2/122
ipv6 ospf 6 area 0
frame-relay interface-dlci 302
!
interface Serial0/0/0/0.34 point-to-point
description Link to R4
ip address 10.1.1.9 255.255.255.252
frame-relay interface-dlci 304
!
router ospf 1
area 34 nssa no-summary
network 3.3.3.3 0.0.0.0 area 0
network 10.1.1.4 0.0.0.3 area 0
network 10.1.1.8 0.0.0.3 area 34
!
ipv6 router ospf 6
!
end

GRE Tunnel って何?という感じでしたが、だいたい理解できました。
http://www.infraexpert.com/study/rp8gre2.htm
http://atnetwork.info/ccnp4/vpn17.html
http://www.ccstudy.org/study/ipsec/gre/gre.html

が、OSPFv3はインターフェースでエリア設定したりで
こんがりまくります。

————————————————————
R2のコンフィグ
hostname R2
ipv6 unicast-routing
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
ipv6 address FEC0::2:2/122
ipv6 ospf 6 area 0
!
interface Serial0/0/0/0.12 point-to-point
description Link to R1
ip address 10.1.1.2 255.255.255.252
ipv6 address 2026::12:2/122
ipv6 ospf 6 area 12
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 pass
frame-relay interface-dlci 201
!
interface Serial0/0/0/0.23 point-to-point
description Link to R3
ip address 10.1.1.5 255.255.255.252
ipv6 address 2026::1:1/122
ipv6 ospf 6 area 0
frame-relay interface-dlci 203
!
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 12
network 10.1.1.4 0.0.0.3 area 0
!
ipv6 router ospf 6
!
end

————————————————————
R1のコンフィグ
hostname R1
!
ipv6 unicast-routing
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ipv6 address FEC0::1:1/122
ipv6 ospf 6 area 12
!
interface Serial0/0/0/1
description Link to ISP 65002
ip address 209.65.200.225 255.255.255.252
ip nat outside
ip access-group 30 in
!
interface Serial0/0/0/0.12 point-to-point
description Link to R2
ip address 10.1.1.1 255.255.255.252
ip nat inside
ipv6 address 2026::12:1/122
ipv6 ospf 6 area 12
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 pass
frame-relay interface-dlci 102
!
router ospf 1
network 1.1.1.1 0.0.0.0 area 12
network 10.1.1.0 0.0.0.3 area 12
!
router bgp 65001
no synchronization
network 209.65.200.224 mask 255.255.255.252
neighbor 209.65.200.226 remote-as 65002
no auto-summary
!
ipv6 router ospf 6
!
ip nat inside source list nat_pool interface Serial0/0/0/1 overload
ip access-list standard nat_pool
permit 10.1.0.0
permit 10.2.0.0
!
access-list 30 permit host 209.65.200.241
access-list 30 permit 209.65.200.224 0.0.0.3
access-list 30 deny 10.1.0.0 0.0.255.255
access-list 30 deny 10.2.0.0 0.0.255.255
!
end

必要箇所だけにして、順番は入れ替えたりしています。
NATを名前つきACLにして
別のACLを追加しています

引用元: CCNP TSHOOT 642-832 勉強中.

スポンサーリンク
  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク

コメントを残す